Deekin 4ever

January 7, 2010
Computer Stuff / Indeo Video IV50 on Windows 7 Fix

Running into unnecessary problems trying to play a movie encoded with the accursed IV50 codec? I sure did. Some of my AVI videos were encoded with the Ligos Indeo XP Video codec awhile back via Pinnacle Studio 8.12.7, and has since stirred up a fuss trying to let me access them in Windoze 7. After much scouring the search results and tinkering and testing stuff, I believe I finally have that gremlin drawn and quartered.

First and foremost, you will need the Ligos Indeo Legacy Package (IV31, IV32, IV41, IV50, YVU9), which I believe is freeware according to my source. It will install Indeo Video codecs for 3, 4, 5, and Indeo Raw (YVU9). The filesize should be about 2,068,266 bytes. You can get it at...

Indeo Codecs Legacy Package (IV31, IV32, IV41, IV50)

Once installed, incredibly enough (believe it or not) you may still run into problems opening your IV50 encoded video. Why? That's because the Indeo installer FAILED (tch! tch!) to register the dll on Windows 7! Is it Indeo's fault, or WINDOZE SEVEN's fault, or BOTH? Who knows? Who cares? OK, I do, but that's a debate for another time. Right now I am itching to share the solution for the good of all mankind.

So go ahead and click that round Microsoft thingy at the bottom leftmost part of your desktop. Then click on All Programs followed by Accessories. Look for Command Prompt and right-click on it. Then click on Run as administrator. Helloooo, are you paying attention there? There's a reason why it's ITALICIZED and BOLDED! I cannot stress enough how *VERY* important this Run as administrator priviledge is, which is a very common problem in Windows 7 with some programs. Ignore it for this instance, and you will be smacked with a pop-up window out of nowhere happily informing you that "... the codec was loaded but the call to DllRegisterServer failed with the error code 0x8000ffff".

Assuming that you had followed the given instructions right down to the letter, you should be idling at the command prompt right now. Go ahead and type in the following:

regsvr32 ir50_32.dll

Press your Enter key, and voila, *hopefully* your problem should be solved. I know it did mine.


< Previous

Tagged as: Tagged as dll, indeo, indeo iv50, indeo video, iv31, iv32, iv41, iv50, iv50 error, iv50 fix, iv50 help, iv50 problem, ligos, ligos indeo, pinnacle studio, regsvr32, run as administrator, win 7, win7, windows 7, windoze 7, yvu9

Leave a Comment
 Name (required)
 E-mail (will not be published)

  1. Frank Hayden
    January 26th, 2012 - 05:37
    thank you
  2. Jim H
    December 22nd, 2011 - 14:31
    It worked great on my Win 7 Pro x64… once I issued the following command immediately after reaching the C: prompt:
    cd \windows\syswow64
    Then I typed the regsvr command line.
  3. Vasily Klimov
    October 11th, 2011 - 07:45
    Thank you very much. It works
  4. Pasquale
    October 8th, 2011 - 15:20
    Grazie pure a me , funziona per bene!! lavoro con win 7 pro 32 bit
  5. Bernal Thalman
    October 7th, 2011 - 18:52
    using regsvr32 ir50_32dll works!!! Thankyou
    Trabajó mi avi indeo. Gracias
  6. pepelule
    October 2nd, 2011 - 20:05
    It works for me. Thanks a lot. Remember to open video files in windows media player if other programs dont works.
  7. Tazman
    September 14th, 2011 - 12:04
    Thank you, it works
  8. John
    September 3rd, 2011 - 20:00
    above file do install except for some cases when u press install it just loads 1 sec then the program closes. it seem it has not been installed but it does work.
    And thanks very much, it worked on windows 7 x32 home plus
  9. Steven
    August 18th, 2011 - 11:26
    oh, and i’m using Win 7 x64 Pro…
  10. Steven
    August 18th, 2011 - 11:25
    I have tried all the steps as written, and nothing has worked. no idea what i’m doing wrong. and i’m not sure that the ir50_32.dll is the authentic one required to play the videos right. any ideas? i’ve tried many things
  11. Poisoned Dragon
    August 7th, 2011 - 13:52
    I figured out that if you run the exe file with administrator privilages, from the start, it will successfully register the codec for you. Just right-click the exe file, and select “Run as Administrator”. I’m using Windows 7 x64 and it works great. Hope that helps.
  12. ian s
    August 1st, 2011 - 22:59
    Whoa, it worked for me too! Thanks so much! After installing the codec I used the fantastic crap-tatic encoder Super to convert my old videos to a more standard format. Geez, you’d think VLC would read these old codecs. I guess it’s legal IP issues which prevents VLC from support these tired old codecs.
  13. sEi
    July 6th, 2011 - 15:35
    The above didnt install so i just downloaded the “ir50_32.dll” from the net. Put it in “C:\Windows\System32? and do the “regsvr32 ir50_32.dll” in a (Run as administrator) DOS prompt. viola it works – thnx to the OP.
  14. David Ivan
    July 5th, 2011 - 11:41
    It worked for me too! Thanks a lot! ^^
  15. A
    June 29th, 2011 - 02:43
    Worked – thank you.
  16. Levie
    May 24th, 2011 - 03:18
    Worked for me too~
    Thank you very much!
  17. Bonsie
    May 2nd, 2011 - 09:45
    Thanks a million. I’ve been looking for over 5 years for help to open/view these video clips. Some of them are of my late father and grandmother and they were in this format only! It has been wonderful to be able to go down memory lane and be able to share them with everyone again.
    Know I need to look for something to convert them to another format before I lose them again
    Once again thank you very much!
  18. Oliver
    April 14th, 2011 - 03:06
    THANK YOU!!! – this is an understatement…. Can’t thank you enough
  19. frank
    April 10th, 2011 - 21:10
    thank youuuuuuuu or GRACIAS !! from Argentina! worked 100%
  20. Anjelous
    March 29th, 2011 - 23:44
    Thank you so much, i have been trying to figure out how on earth to get indeo working on Win7 for ages, this did the trick
  21. amellor
    March 7th, 2011 - 10:33
    Worked for me with Win7 Pro 32
    Thankyou very much
  22. Chatworthy
    January 30th, 2011 - 22:43
    This fix worked great on my win 7 64 – solved the legacy problems of 5.x – can’t thank you enough!
  23. Matt
    January 9th, 2011 - 09:56
    What about on WINDOWS 7 64 BIT? It doesn’t work for me.
    Are there Windows 7 64 Bit instructions?
    Please Help!
    Thank you!
  24. mario
    January 2nd, 2011 - 10:48
    great, you’re great, I have 3 years can not solve the problem and in five minutes you’ve solved. works, thanks.
  25. CaptJIM
    January 2nd, 2011 - 00:35
    Thanks! You guys are genious! I can finally play my old AVI files on my Windows 7 machine that were created with a Logitech web cam on an old PC. None of the common, popular fixes worked for me, such as the K-lite codec pack, the DIVX player, or the AVL player. Woohoo!!!
  26. Del
    December 2nd, 2010 - 14:38
    Man, being a technician I should have thought of that.
    Thank you so much for taking the time to post about this. It worked for me.
  27. bigkon
    December 1st, 2010 - 16:44
    Great work! Thanks alot, it’s really works!
  28. Jc
    November 30th, 2010 - 23:07
    Worked on Win7 x64 bit for me, thanks, took a bit to find this page but it was worth it.
  29. Boshko
    November 29th, 2010 - 14:32
    If you can not start Indeo Video Search: -ir50_32- in -C: / Users / ? (**********) ? / Recent- copy the file and paste it in: C: / Users /,,, so as Find file: regsvr32 and paste it in: C: / Users /
    (*********) = Name of your PC , in my case its: C: / Users /b
    Probably i have strange version of win 7
  30. Matías
    November 12th, 2010 - 06:31
    Thanks a lot man! That was exactly what I was looking for!
  31. hasam1988
    November 5th, 2010 - 08:50
    thannks very
    WIN 7 _I love win 7
  32. inutil
    October 30th, 2010 - 07:23
  33. Alex
    October 30th, 2010 - 10:50
    Thanks, thanks, thanks, thanks!!!!!!!!!!!!!!!!!
  34. Dangerbod
    October 20th, 2010 - 12:29
    Brilliant I’ve been searching for a solution to this all week! :0)
  35. Hendi Hendratman
    October 29th, 2010 - 04:22
    A Lot of Thanks! Now I can work in win 7
  36. emv
    October 3rd, 2010 - 01:53
    I had to use “regsvr32? instead of just plain “regsvr” and then it worked beautifully.
  37. Gabo
    October 2nd, 2010 - 14:45
    Why does it say “The module ‘ir50_32.dll’ failed to load.”? How do I solve this?
  38. Fredijs
    September 28th, 2010 - 05:44
    thank you man!!
  39. azrezul
    September 29th, 2010 - 23:17
    thank you very much…
  40. Alice
    September 28th, 2010 - 05:28
    GREAT!Thank you so much!!!!!
  41. ceemosp
    September 18th, 2010 - 09:09
    Right clicking the installer and selecting “run as administrator” also
    worked fine on my end!
    August 19th, 2010 - 19:50
    Great man~~! Thanks~~! I solved the problem…..
  43. Kropek
    August 11th, 2010 - 15:56
    I Love You. F*** that I male too, I just love You for Your solution :* :D Poland sends greetings!
  44. peter lemonjello
    August 7th, 2010 - 20:16
    this worked great thanks any chance for a fix with this C00D11B1 for windows 7 also?
  45. Marcelo
    August 7th, 2010 - 16:59
    IT WORKS!!!!!! Thanks from Brazil, man!!!!
  46. Hubby
    August 3rd, 2010 - 15:50
    I had tried it with Media Player Classic, and it works fine. Not sure about VLC though. I should mention that I had installed the K-Lite Codec Pack (FULL), which you can download at Hope that helps in some way.
  47. Steve H
    August 3rd, 2010 - 14:28
    WMP and VLC still won’t play the files. What player are folks using?
  48. Rijkaard
    August 1st, 2010 - 19:59
    Finally i could solve my damn problem!!!!
    Thanks Man…
  49. Jesper
    July 26th, 2010 - 07:34
    Ok ive tryed that now and it sitll dont work. It tells me that the .dll file arent there and i have to find it manually.
    Aparantly it dont work on some machines, cos i got it to work in the wifes pc, but not mine.
    If any have a othe solution plz share
  50. mrco
    July 25th, 2010 - 06:52
    Big Thanks!
  51. Dharmieri
    July 11th, 2010 - 12:23
    Thx Bro It realle wors on my acer windows 7.. just install it and it is done..
  52. Kurt
    July 7th, 2010 - 14:21
    Awesome! Totally works.
  53. Rider19lh
    June 25th, 2010 - 22:23
    Works wonders. Thanks man!
  54. Matt80
    June 24th, 2010 - 09:01
    Wow! That’s awesome! It worked flawlessly!!
  55. Andreas
    June 23rd, 2010 - 23:27
    man thank you! you are the best! it worked immediately
  56. DG
    June 19th, 2010 - 07:29
    I tried your suggestion and I didn’t work. I got the error “the module failed to load. Make sure the binary is stored at the specific path or debug it to check for problems with the binary or dependent .dll files.
    The specific module could not be found.” I did download the codecs package first so I am lost as to why that error comes up. I am not all that computer savvy, but I think I did everything right. Any suggestions?
  57. Saladin211
    June 12th, 2010 - 19:25
    Thank you v.much… at last it works in 1 second.. thanks!!
  58. BR549
    June 7th, 2010 - 16:56
    Thanks! I had to go around the damn world to find this. Just to play some cheesy old vids my friend sent me from his webcam LOL
  59. Shawn
    June 2nd, 2010 - 07:13
    Thank you so much!!!!
  60. Lolo
    May 20th, 2010 - 14:22
    Thanks a lot !
    I was facing this problem on a win Vista 32bits, and your solution
    >worked like a charm.
  61. Hubby
    May 18th, 2010 - 20:58
    Thanks for the update. Which reminds me. I should mention that the problem with the codec and solution was experienced on Windows 7 32-bit.
  62. John
    May 18th, 2010 - 20:44
    Just installed the codec and it works (windows 7 64bits)
    no need to register
  63. Darkman
    May 1st, 2010 - 09:27
    thank you very much! you are a genius!
  64. i love you
    April 26th, 2010 - 10:17
    holy shit it works – it took me 3 days to fix this shit!
  65. John McGeoch
    April 16th, 2010 - 21:47
    Bloody great medal to you mate – I was just looking at 5 years of wasted VJ material – many many thanks
  66. KILLL
    April 10th, 2010 - 09:04
    your a superman dude >>thxxxxxxxx
  67. Not-Matt
    April 1st, 2010 - 05:45
    Many thanks from Italy.
  68. higgins
    March 29th, 2010 - 18:51
    yeehaa finaly ty…
  69. Peter Briggs
    March 17th, 2010 - 05:01
    Brilliant. After hours of searching you have come up with the solution
    I could find nowhere else. Thank you so much!
  70. mina
    March 1st, 2010 - 12:53
    I want to thank u so much
  71. Hubby
    February 18th, 2010 - 20:57
    Glad it worked out for you guys! :)
  72. paul
    February 17th, 2010 - 12:47
    I love you.
    10 hours trying to open these files…
    and your solution worked in 15 seconds
  73. steve
    February 4th, 2010 - 23:27
    Brilliant! It works. Thankyou so much!


the following links does not work... yet...



Indeo Video IV50 Star Wars Dark Forces HP Laserjet 1020 on Win7